hdu1423---Greatest Common Increasing Subsequence

194 篇文章 0 订阅

Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output
output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1 5 1 4 2 5 -12 4 -12 1 2 4

Sample Output

2

Source
ACM暑期集训队练习赛(二)

Recommend
lcy | We have carefully selected several similar problems for you: 1422 1400 1418 1424 1401

求最长公共上升子序列

设dp[i][j] 表示a的前i个数和b的前j个数,以b[j]结尾的LCIS长度
如果a[i] != b[j]
令dp[i][j] = dp[i - 1][j]; //即取上一次的最优解
如果a[i] == b[j]
那么dp[i][j] = max (dp[i - 1][k]) + 1;
加以优化,复杂度可以控制在O(m*n)

/*************************************************************************
    > File Name: hdu1423.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年02月21日 星期六 19时12分48秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int N = 510;
int dp[N][N];
int a[N];
int b[N];

int main ()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        int n, m;
        scanf("%d", &n);
        for (int i = 1; i <= n; ++i)
        {
            scanf("%d", &a[i]);
        }
        scanf("%d", &m);
        for (int i = 1; i <= m; ++i)
        {
            scanf("%d", &b[i]);
        }
        memset (dp, 0, sizeof(dp));
        for (int i = 1; i <= n; ++i)
        {
            int maxs = 0;
            for (int j = 1; j <= m; ++j)
            {
                dp[i][j] = dp[i - 1][j];
                if (a[i] > b[j] && maxs < dp[i][j])
                {
                    maxs = dp[i][j];
                }
                if (a[i] == b[j])
                {
                    dp[i][j] = maxs + 1;
                }
            }
        }
        int ans = 0;
        for (int i = 1; i <= m; ++i)
        {
            ans = max (dp[n][i], ans);
        }
        printf("%d\n", ans);
        if (t)
        {
            printf("\n");
        }
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值