Description
When a thin rod of length L is heated n degrees, it expands to a new length L' = (1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.
Your task is to compute the distance by which the center of the rod is displaced. That means you have to calculate h as in the picture.
Input
Input starts with an integer T (≤ 20), denoting the number of test cases.
Each case contains three non-negative real numbers: the initial length of the rod in millimeters L, the temperature change in degrees n and the coefficient of heat expansion of the material C. Input data guarantee that no rod expands by more than one half of its original length. All the numbers will be between 0 and 1000 and there can be at most 5 digits after the decimal point.
Output
For each case, print the case number and the displacement of the center of the rod in single line. Errors less than 10-6 will be ignored.
Sample Input
3
1000 100 0.0001
150 10 0.00006
10 0 0.001
Sample Output
Case 1: 61.3289915
Case 2: 2.2502024857
Case 3: 0
刚开始的时候二分的角,WA,所以换了一个常规的,直接二分 要求的结果的那个变量高H。
code:
#if 0 //xpanding Rods
#include<iostream>
#include<iomanip>
#include<cmath>
#include<algorithm>
using namespace std;
const double pai=3.1415926535897;
double x,x1,n,c;
int fun(double h)
{
double R=(pow(x,2)+4*pow(h,2))/(8*h);
double O=asin(x/(2*R));
double xx=2*O*R;
if(xx<=x1)
{
return 1;
}
else
{
return 0;
}
}
int main()
{
while(cin>>x>>n>>c)
{
if(x==-1&&n==-1&&c==-1)
{
break;
}
x1=(1.0+n*c)*x; //加热后的长度
double l=0.0,r=x/2; //二分 高度 的度数
while((r-l)>=1e-6)
{
double mid=(r+l)/2.0;
if(fun(mid)==1) //小了
{
l=mid;
}
else
{
r=mid;
}
}
cout<<fixed<<setprecision(3)<<l<<endl;
}
}
#endif