A Cubic number and A Cubic Number

A Cubic number and A Cubic Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=27 so 27 is a cubic number. The first few cubic numbers are 1,8,27,64 and 125 . Given an prime number p . Check that if p is a difference of two cubic numbers.
 

Input
The first of input contains an integer T (1T100) which is the total number of test cases.
For each test case, a line contains a prime number p (2p1012) .
 

Output
For each test case, output 'YES' if given p is a difference of two cubic numbers, or 'NO' if not.
 

Sample Input
  
  
10 2 3 5 7 11 13 17 19 23 29
 

Sample Output
  
  
NO NO NO YES NO NO NO YES NO NO
 

Source
  
  
输入输出测试
 未AC代码:因为超内存
#include<stdio.h>
#include<iostream>
using namespace std;
long num[10000];
long subnum[80000000];
int main(){
	int n,t;
	int i,j;
	int x,y;
	cin>>n;
	int cnt=1;
	int flag=0;
	for(i=1;i<=10000;i++){
		num[i] = i*i*i;
	}
	for(i=1;i<=10000;i++){
		for(j=1;j<i;j++){
			subnum[cnt++]=num[i]-num[j];
		}
	}
	for(x=1;x<=n;x++){
		cin>>t;
		for(y=1;y<=cnt;y++){
			if(t==subnum[y]){
				flag=1;
				break;
			}
			else{
				flag=0;
			}
		}
		if(flag==1)
		printf("YES\n");
		else
		printf("NO\n");
	}	
}
AC代码:
#include<stdio.h>
#include<iostream>
using namespace std;
long long subnum[1000000];
int main(){
	long long n,t;
	long long i,j;
	int x,y;
	cin>>n;
	long cnt=1;
	int flag=0;

	for(i=1;i<=1000000;i++){
	
			subnum[cnt++]=i*i*i-(i-1)*(i-1)*(i-1);
		}
	

	for(x=1;x<=n;x++)
	{
		cin>>t;
		long long pos;
		pos = lower_bound(subnum,subnum+cnt,t)-subnum;
		if(subnum[pos]==t)
		printf("YES\n");
		else
		printf("NO\n");
	}	
	return 0;
}
如果两个数的立方差是素数,那么这两个数必定相邻。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值