Parity HDU 2700



Parity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2770    Accepted Submission(s): 2139


Problem Description
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of
0's does not affect the parity of a bit string.
 

Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase letter 'o'.
 

Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the letter was 'o').
 

Sample Input
  
  
101e 010010o 1e 000e 110100101o #
 

Sample Output
  
  
1010 0100101 11 0000 1101001010
 

Source

这个题卡了半天。。。。原因就是循环里面下表上限搞错了。。。。
#include<stdio.h>
#include<string.h>

char st[50];
int len,k,i;

int main()
{
   while(gets(st) != NULL && st[0]!='#')
   {
       len = strlen(st);
       k = 0;
       for(i = 0 ;i < len -1;i++)
           if (st[i] == '1') k++;

        if(st[len-1] == 'e' )
        st[len-1] = (k%2!=0) ? '1':'0';

        else if(st[len -1] =='o')
       st[len-1] = (k%2!=0) ? '0':'1';
        puts(st);
   }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值