PAT A1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题意:

计算a,b的和,并且每隔3位(自高位至低位)输出1个逗号.

思路:

(1)将整数转换成字符串进行处理;
(2)将字符串自高位至低位隔3个字符(数字)输出1个逗号;
(3)注意和为0的情况.

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
void change(char c[],int x){//将整数转化为字符串	
	int i=0;
	if(x<0){
		x=abs(x);
	}	
	while(x!=0){
		c[i++]=x%10+'0';
		x/=10;
	}
	reverse(c,c+i);
}
int main(){
	int a,b,c;
	cin>>a>>b;
	c=a+b;
	if(c<0)printf("-");
	else if(c==0)printf("0");//考虑c==0的特殊情况 
	char str[10];
	change(str,c);
	int len=strlen(str);
	for(int i=0;i<len;i++){
		printf("%c",str[i]);
		if((i+1)%3==len%3&&i!=len-1)printf(",");//令(i+1)%3==len%3,使字符串从右至左隔3个字符输出“,” 
	}
	return 0;
}

词汇:

digit 数字
comma 逗号
specification 规范
integer 整数

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值