1107. Social Clusters (30)【并查集】

1107. Social Clusters (30)

时间限制
1000 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] ... hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1


#include <bits/stdc++.h>
#include<vector>
#define ms(x,y) memset(x,y,sizeof(x))
const int M=1e5+10;
using namespace std;
int i,j,k,n,m;
int pre[M];
int father[M];

int findf(int x)
{
    int z=x;
    while(z!=pre[z])
        z=pre[z];
    while(pre[x]!=z){
        int k=pre[x];
        pre[x]=z;
        x=k;
    }
    return z;
}

void Union(int a,int b)
{
    int aa=findf(a);
    int bb=findf(b);
    if(aa!=bb){
        pre[aa]=bb;
    }
}

int main()
{
    int course[1001];
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        pre[i]=i;
    for(int i=1;i<=n;i++){
        int k;
        scanf("%d:",&k);
        for(int j=0;j<k;j++){
            int t;scanf("%d",&t);
            if(course[t]==0)course[t]=i;
            Union(i,course[t]);
        }
    }
    int ans=0,cnt[M];
    memset(cnt,0,sizeof(cnt));
    for(int i=1;i<=n;i++)cnt[findf(i)]++;
    for(int i=1;i<=n;i++){
        if(cnt[i]!=0)ans++;
    }
    printf("%d\n",ans);
    sort(cnt+1,cnt+n+1);
    for(int i=n;i>n-ans;i--){
        if(i<n)printf(" %d",cnt[i]);
        else printf("%d",cnt[i]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值