hdoj-5904 LCIS

原题链接

LCIS

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 444    Accepted Submission(s): 203


Problem Description
Alex has two sequences  a1,a2,...,an  and  b1,b2,...,bm . He wants find a longest common subsequence that consists of consecutive values in increasing order.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains two integers  n  and  m   (1n,m100000)  -- the length of two sequences. The second line contains  n  integers:  a1,a2,...,an   (1ai106) . The third line contains  n  integers:  b1,b2,...,bm   (1bi106) .

There are at most  1000  test cases and the sum of  n  and  m  does not exceed  2×106 .
 

Output
For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.
 

Sample Input
  
  
3 3 3 1 2 3 3 2 1 10 5 1 23 2 32 4 3 4 5 6 1 1 2 3 4 5 1 1 2 1
 

Sample Output
  
  
1 5 0

用map不然会超时

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <map> 
#define maxn 100005
#define MOD 1000000007
#define INF 1e9
using namespace std;
typedef long long ll;

int num1[100005], num2[100005];
map<int, int> dp1, dp2;
int main(){
    
//    freopen("in.txt", "r", stdin);
    int t;
    
    scanf("%d", &t);
    while(t--){
        
        dp1.clear();
        dp2.clear();
        int n, m;
        
        scanf("%d%d", &n, &m);
        for(int i = 0; i < n; i++)
         scanf("%d", num1+i);
        for(int i = 0; i < m; i++)
         scanf("%d", num2+i);
        for(int i = n-1; i >= 0; i--){
            dp1[num1[i]] = dp1[num1[i]+1] + 1;
        }
        for(int i = m-1; i >= 0; i--){
            dp2[num2[i]] = dp2[num2[i]+1] + 1;
        }
        int maxs = 0;
        map<int, int> ::iterator iter = dp1.begin();
        for(; iter != dp1.end(); iter++){
            maxs = max(maxs, min(iter->second, dp2[iter->first]));
        }
        printf("%d\n", maxs);
    }
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值