hdoj5867Water problem

Water problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 215    Accepted Submission(s): 146


Problem Description
If the numbers 1 to 5 are written out in words: one, two, three, four, five, then there are 3+3+5+4+4=19 letters used in total.If all the numbers from 1 to n (up to one thousand) inclusive were written out in words, how many letters would be used?

Do not count spaces or hyphens. For example, 342 (three hundred and forty-two) contains 23 letters and 115 (one hundred and fifteen) contains 20 letters. The use of "and" when writing out numbers is in compliance with British usage.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases.

For each test case: There is one positive integer not greater one thousand.
 

Output
For each case, print the number of letters would be used.
 

Sample Input
  
  
3 1 2 3
 

Sample Output
  
  
3 6 11
 

Author
BUPT
 

Source
 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
#include<map>
using namespace std;
typedef long long LL;
typedef pair<int,int>pii;
const int maxn=1010;
int num[maxn];
void Count(){
    num[0]=0;num[1]=num[2]=3;num[3]=5;num[4]=num[5]=4;num[6]=3;num[7]=5;num[8]=5;num[9]=4;num[10]=3;num[100]=10;
    num[11]=6;num[12]=6;num[13]=8;num[14]=8;num[15]=7;num[16]=7;num[17]=9;num[18]=8;num[19]=8;num[20]=6;num[30]=6;num[40]=5;
    num[50]=5;num[60]=5;num[70]=7;num[80]=6;num[90]=6;
    for(int i=2;i<=9;++i){
        for(int j=1;j<=9;++j){
            num[i*10+j]=num[i*10]+num[j];
        }
    }
    for(int i=2;i<=9;++i){
        num[i*100]=num[i]+7;
    }
    for(int i=1;i<=9;++i){
        for(int j=1;j<=99;++j){
            num[i*100+j]=num[i]+num[j]+10;
        }
    }num[1000]=11;
    for(int i=1;i<=1000;++i){
        num[i]+=num[i-1];
    }
}
int main()
{
    Count();
    int t;scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        printf("%d\n",num[n]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值