集训队专题(2)1005 A Simple Math Problem

A Simple Math Problem

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 25   Accepted Submission(s) : 23
Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file. In each case, there will be two lines. In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 ) In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104
 

Author
linle
 

Source
2007省赛集训队练习赛(6)_linle专场
 

此题也算是比较基础的矩阵快速幂的题了吧,函数构造如下:

|f(10) | |a0 a1 a2 ...a8 a9| |f(9)|
| f(9) | | 1 0 0 ... 0 0| |f(8)|
| .....| = |.. ... ... ... ..| | .. |
| f(2) | | 0 0 0 ... 0 0| |f(1)|
| f(1) | | 0 0 0 ... 1 0| |f(0)|

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
__int64 k,mod;
struct Matrix
{
	int a[12][12];
};
Matrix unit,init;
void Init()
{
	memset(init.a,0,sizeof(init.a));
	for(int i=1; i<10; i++)
		init.a[i][i-1] = 1;
	memset(unit.a,0,sizeof(unit.a));
	for(int i=0; i<10; i++)
		unit.a[i][i] = 1;
}
Matrix multi(Matrix a,Matrix b)
{
	Matrix c;
	for(int i=0; i<10; i++)
		for(int j=0; j<10; j++)
		{
		c.a[i][j] = 0;
			for(int k=0; k<10; k++)
			{
				c.a[i][j] += (a.a[i][k] * b.a[k][j]) % mod;
				c.a[i][j] %= mod;
			}
		}
	return c;
}
Matrix fast_mod(Matrix a,Matrix b,int x)
{
	while(x)
	{
		if(x&1)
			b = multi(a,b);
		a = multi(a,a);
		x >>= 1;
	}
	return b;
}
int main()
{
	while(scanf("%I64d%I64d",&k,&mod)!=EOF)
	{
		Init();
		for(int i=0; i<10; i++)
			scanf("%d",&init.a[0][i]);
		if(k<10)
		{
			printf("%d\n",k%mod);
			continue;
		}
		Matrix res=fast_mod(init,unit,k-9);
		int ans=0;
		for(int i=0; i<10; i++)
			ans += (res.a[0][i]*(9-i))%mod;
		printf("%d\n",ans%mod);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值