集训队专题(4)1003 Activation

Activation

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2597    Accepted Submission(s): 897


Problem Description
After 4 years' waiting, the game "Chinese Paladin 5" finally comes out. Tomato is a crazy fan, and luckily he got the first release. Now he is at home, ready to begin his journey.
But before starting the game, he must first activate the product on the official site. There are too many passionate fans that the activation server cannot deal with all the requests at the same time, so all the players must wait in queue. Each time, the server deals with the request of the first player in the queue, and the result may be one of the following, each has a probability:
1. Activation failed: This happens with the probability of p1. The queue remains unchanged and the server will try to deal with the same request the next time.
2. Connection failed: This happens with the probability of p2. Something just happened and the first player in queue lost his connection with the server. The server will then remove his request from the queue. After that, the player will immediately connect to the server again and starts queuing at the tail of the queue.
3. Activation succeeded: This happens with the probability of p3. Congratulations, the player will leave the queue and enjoy the game himself.
4. Service unavailable: This happens with the probability of p4. Something just happened and the server is down. The website must shutdown the server at once. All the requests that are still in the queue will never be dealt.
Tomato thinks it sucks if the server is down while he is still waiting in the queue and there are no more than K-1 guys before him. And he wants to know the probability that this ugly thing happens.
To make it clear, we say three things may happen to Tomato: he succeeded activating the game; the server is down while he is in the queue and there are no more than K-1 guys before him; the server is down while he is in the queue and there are at least K guys before him.
Now you are to calculate the probability of the second thing.
 

Input
There are no more than 40 test cases. Each case in one line, contains three integers and four real numbers: N, M (1 <= M <= N <= 2000), K (K >= 1), p1, p2, p3, p4 (0 <= p1, p2, p3, p4 <= 1, p1 + p2 + p3 + p4 = 1), indicating there are N guys in the queue (the positions are numbered from 1 to N), and at the beginning Tomato is at the Mth position, with the probability p1, p2, p3, p4 mentioned above.
 

Output
A real number in one line for each case, the probability that the ugly thing happens.
The answer should be rounded to 5 digits after the decimal point.
 

Sample Input
  
  
2 2 1 0.1 0.2 0.3 0.4 3 2 1 0.4 0.3 0.2 0.1 4 2 3 0.16 0.16 0.16 0.52
 

Sample Output
  
  
0.30427 0.23280 0.90343
 

Source
 

又是一个题目超长的英文题,需要静下心来认真读题。

题意:有n个人在官网上排队激活游戏,Tomato排在队伍的第m个,在队列中有以下4种情况:

1.Activation failed(激活失败),第一个留在队列中等待下一次激活,概率为p1;

2.Connection failed(失去连接),第一个排到队伍的最后一个,概率为p2;

3.Activation succeeded(激活成功),第一个离开队伍,概率为p3;

4.Service unavailable(服务器瘫痪),服务器停止激活,所有人都无法激活,概率为p3;

题目要求我们求出服务器瘫痪是在队列中的位置为第k个的概率。

此题我们采取的方法为概率DP求解,设dp[i][j]表示有i个人在排队,Tomato排在第j个位置,达到目标状态的期望,我们需要求得的就是dp[n][m]。不难得出:

j == 1: dp[i][1]=p1*dp[i][1]+p2*dp[i][i]+p4;
2 <= j <= k: dp[i][j]=p1*dp[i][j]+p2*dp[i][j-1]+p3*dp[i-1][j-1]+p4;
k <= j <= i: dp[i][j]=p1*dp[i][j]+p2*dp[i][j-1]+p3*dp[i-1][j-1];

经过化简我们可以得到:

j == 1: dp[i][1]=p21*dp[i][i]+p41;
2 <= j <= k: dp[i][j]=p21*dp[i][j-1]+p31*dp[i-1][j-1]+p41;
k <= j <= i: dp[i][j]=p21*dp[i][j-1]+p31*dp[i-1][j-1];

其中为了方便书写:

p21 = p2/(1-p1);
p31 = p3/(1-p1);
p41 = p4/(1-p1);

此时我们进行DP求解,在次过程中每个方程的后面的dp[i][j-1]在状态转移到此方程时,都已经在之前的状态转移过程中得到了求解,所以相当于已经是一个常数,在这里我们为了方便书写,设后面的所有常数为c[i],则方程变为:

j == 1: dp[i][1]=p21*dp[i][i]+c[1];
2 <= j <= k: dp[i][j]=p21*dp[i][j-1]+c[j];
k <= j <= i: dp[i][j]=p21*dp[i][j]+c[j];

接下来就是我们的DP方程迭代求解了,将上面耳朵方程迭代我们可以得到:

dp[i][i] = (...(((dp[i][i]*p21)+c[1])*p21+c[2])*p21+c[3])...)*p21+c[i];

只要一层一层的DP求解我们便可以得到我们要求的dp[n][m]。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define eps 1e-10
using namespace std;
double p1,p2,p3,p4,p21,p31,p41;
double dp[2005][2005],c[2005];
int n,m,k;
int main()
{
    while(scanf("%d%d%d%lf%lf%lf%lf",&n,&m,&k,&p1,&p2,&p3,&p4)!=EOF)
	{
        if(fabs(p4) < eps) {puts("0.00000");continue;}
        p21=p2/(1-p1);
        p31=p3/(1-p1);
        p41=p4/(1-p1);
        dp[1][1]=p4/(1-p1-p2);
        for(int i=2;i<=n;i++)
		{
            for(int j=2;j<=(i<k?i:k);j++)
               c[j]=dp[i-1][j-1]*p31+p41;
            for(int j=k+1;j<=i;j++)
               c[j]=dp[i-1][j-1]*p31;
            double p=1,tmp=0;
            for(int j=i;j>1;j--)
			{
                tmp+=p*c[j];
                p*=p21;
            }
            dp[i][i]=(tmp+p*p41)/(1-p*p21);
            dp[i][1]=p21*dp[i][i]+p41;
            for(int j=2;j<i;j++)
               dp[i][j]=p21*dp[i][j-1]+c[j];
        }
        printf("%.5f\n",dp[n][m]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值