HDOJ 1009 FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60482    Accepted Submission(s): 20335


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

Author
CHEN, Yue
 

Source
 
此题为简单的贪心题,因为这里我们可以按比例进行交换,而不是一次就必须取完,所以我们肯定是直接按照性价比最大的先取(如果不是按比例取,而是一次必须取完的话,这里就需要用到01背包的思想,这里请读者自己思考),既然涉及到贪心,必然少不了排序,算出
#include<stdio.h>
int main()
{
    int a,b;
    int m[1000],n[1000];
    double k[1000],s,t;
    int i,j;
    while(scanf("%d%d",&a,&b)&&(a+1)||(b+1))
    {
    	s=0;
    	for(i=0;i<b;i++)
    	{
        	scanf("%d%d",&m[i],&n[i]);
            k[i]=(double)m[i]/n[i];
    	}
    	for(i=0;i<b-1;i++)
        	for(j=0;j<b-i-1;j++)
            {
                if(k[j]<k[j+1])
                {
                    t=k[j]; k[j]=k[j+1]; k[j+1]=t;
                    t=m[j]; m[j]=m[j+1]; m[j+1]=t;
                    t=n[j]; n[j]=n[j+1]; n[j+1]=t;
                }
            }
        i=0;
        while(a>=n[i]&&i<b)
        {
            s+=m[i];
            a-=n[i];
            i++;         
        }
        if(a>0&&i<b)
        s+=(double)a/n[i]*m[i];
        printf("%.3llf\n",s);
    }
    return  0;
}

每个的性价比,然后再进行排序后从高取到低即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值