集训队专题(6)1004 Card Game Cheater

Card Game Cheater

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1672    Accepted Submission(s): 891


Problem Description
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):


If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.


If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.


A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.


If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit. 

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. 

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally. 

 

Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD
 

Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

 

Sample Input
  
  
3 1 JD JH 2 5D TC 4C 5H 3 2H 3H 4H 2D 3D 4D
 

Sample Output
  
  
1 1 2
 

Source
 

此题很有意思,我们仍然可以进行二分图处理,把比当前牌点数小的所有牌连上,只需要寻找到最大匹配,就是我们要求的得到的分数,在比较点数的时候我们还可以用到的一个小技巧,可以把任意一张牌的点数以一定的规律化成新的点数,已方便进行比较。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 55;
int n,A[maxn],B[maxn];
int g[maxn][maxn],linker[maxn];
bool used[maxn];
bool dfs(int u)
{
	int v;
	for(v=1; v<=n; v++)
		if(g[u][v] && !used[v])
		{
			used[v] = true;
			if(linker[v]==-1 || dfs(linker[v]))
			{
				linker[v] = u;
				return true;
			}
		}
	return false;
}
int hungary()
{
	int res = 0;
	int u;
	memset(linker,-1,sizeof(linker));
	for(u=1; u<=n; u++)
	{
		memset(used,0,sizeof(used));
		if(dfs(u)) res++;
	}
	return res;
}
void init()
{
	char c,d,e;
	int val,flag = 1,ap=0,bp=0;
	for(int i=0; i<2*n; i++)
	{
		scanf("%c%c%c",&c,&d,&e);
		if(c>='0' && c<='9') val = c-'0';
		if(c=='T') val = 10; 
        if(c=='J') val = 11; 
        if(c=='Q') val = 12; 
        if(c=='K') val = 13; 
        if(c=='A') val = 14; 
        val *= 10; 
        if(d=='H') val += 4; 
        if(d=='S') val += 3; 
        if(d=='D') val += 2; 
        if(d=='C') val += 1; 
        if(flag) A[++ap] = val;
        else B[++bp] = val;
        if(e == '\n') flag = 0;
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		getchar();
		init();
		memset(g,0,sizeof(g));
		for(int i=1; i<=n; i++)
		{
			for(int j=1; j<=n; j++)
			{
				if(A[i] < B[j]) g[j][i] = 1;
			}
		}
		int ans = hungary();
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值