HDOJ 1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19127    Accepted Submission(s): 8218


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

Source
 

此题可以作为KMP算法的入门题目,题意为输入一个母串和一个模板串,在母串中找到一个连续的和模板串一样的子串,再输出其开头索引,若没有就输出-1。

#include <cstdio>
#include <cstring>
#include <iostream>
int a[1000000+10],b[10000+10];
int nex[10000+10];
int n,m;
void getNext()
{
	int j,k;
	j = 0,k = -1;
	nex[0] = -1;
	while(j < m)
	{
		if(k == -1 || b[j] == b[k])
			nex[++j] = ++k;
		else k = nex[k];
	}
}
int KMP_Index()
{
	int i=0, j=0;
	getNext();
	while(i<n && j<m)
	{
		if(j == -1 || a[i] == b[j])
			i++,j++;
		else j = nex[j];
	}
	if(j == m) return i-m+1;
	else return -1;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&m);
		for(int i=0; i<n; i++)
			scanf("%d",&a[i]);
		for(int i=0; i<m; i++)
			scanf("%d",&b[i]);
		printf("%d\n",KMP_Index());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值