HDOJ 3746 Cyclic Nacklace

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5480    Accepted Submission(s): 2476


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
  
  
3 aaa abca abcde
 

Sample Output
  
  
0 2 5
 

Author
possessor WC
 



题意:输入一个字符串,问我们最少再填几个字母可以让此字符串形成前缀重复的字符串。

如果对KMP算法的next数组理解比较深入的话这题就比较简单,(i-next[i]) - next[i]%(i-next[i]),可能一些对next数组理解不是很深刻的童鞋不是很懂这个地方,小编我还是在next数组的这个用法上再做一次讲解,next数组本身表示的是前后缀最大匹配长度,不懂得童鞋可以直接动手举例子模拟一下,小编可能有点词穷,i-next[i] 可以表示其重复前缀的长度,也就可以表示前面循环节的长度,如果这里理解了的话,这道题就可以求解了。

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 100005;
char str[maxn];
int nex[maxn];
void getNext(int len)
{
    int i=0, j=-1;
    nex[0] = -1;
    while(i < len)
    {
        if(j == -1 || str[i] == str[j])
            nex[++i] = ++j;
        else j = nex[j];
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",str);
        memset(nex,0,sizeof(nex));
        int len = strlen(str);
        getNext(len);
        int ans = len-nex[len];
        if(ans != len && len%ans == 0) printf("0\n");
        else printf("%d\n",ans-nex[len]%ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值