HDOJ 1358 Period

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5691    Accepted Submission(s): 2743


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

题意:给出一个字符串,让你输出前缀重复的最大次数以及此时的位置索引。

此题的题意很明确,肯定是要用到我们的KMP算法,根据我们的KMP算法的next数组的定义(next数组存的是当前位置最大前缀后缀匹配长度),如果在位置i一个子串是能达到前缀重复效果的话,那么必定会有i-next[i]的值是其最大重复的前缀长度,那么也必定会有i%(i-next[i]) == 0(小编词穷,如果看到这里还是没怎么动的话可以自己动手画一画,应该还是比较好理解的),所以我们就可以运用这个作为一个判定条件,去进行求解。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
const int maxn = 1000000+10;
char str[maxn];
int nex[maxn];
void getNext()
{
	int i=0, j=-1;
	nex[0] = -1;
	while(str[i])
	{
		if(j == -1 || str[i] == str[j])
			nex[++i] = ++j;
		else j = nex[j];
	}
}
void KMP()
{
	int i,t;
	getNext();
	//for(int x=0; str[x]; x++) printf("%d ",nex[x]);printf("\n");
	for(i=2; str[i-1]; i++)
	{
		t = i-nex[i];
		if(i%t == 0 && i/t > 1)
			printf("%d %d\n",i,i/t);
	}
}
int main()
{
	int n,cnt = 1;
	while(scanf("%d",&n) && n)
	{
		scanf("%s",str);
		printf("Test case #%d\n",cnt++);
		KMP();
		printf("\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值