A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.
Sample Input:73 10 23 2 23 10 -2Sample Output:
Yes Yes No
int stoi (const string& str, size_t* idx = 0, int base = 10);//将字符转化为整形int stol (const string& str, size_t* idx = 0, int base = 10);//将字符转化为long
int stoul (const string& str, size_t* idx = 0, int base = 10);//将字符转化为unsigned long
int stoll (const string& str, size_t* idx = 0, int base = 10);//将字符转化为long long
int stoull (const string& str, size_t* idx = 0, int base = 10);//将字符转化为unsigned long long
题意:
给定一个数N,给定一个基数D若N为素数并且将N转化为D进制后反向N’,也为素数
例如23 2
23为素数,将23转化为2进制为10111,反向后为11101是29也为素数所以输出Yes
#include<iostream>
#include<string>
using namespace std;
bool isprime(int n)//判断素数
{
if(n<2)
return false;
for(int i=2;i<=n/2;i++)
if(n%i==0)
return false;
return true;
}
int reverse(int n,int radix)//按进制反向
{
string s;
while(n>0)//求反向radix进制数
{
s.push_back(n%radix+'0');
n/=radix;
}
return stoi(s,nullptr,radix);
}
int main(){
int n,radix;
while(cin>>n&&n>= 0)
{
cin>>radix;
if(isprime(n)&&isprime(reverse(n,radix)))
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
return 0;
}