POJ 2387 Til the Cows Come Home(Dijkstra算法)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

Line 1: Two integers: T and N

Lines 2: T+1:Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

题目大意:

给你一个数t,代表有几条已知的道路,再给出一个数n ,代表有n个点,让你求出从1到n的最短距离为多少

解题思路

标准迪杰斯特拉算法题目
算法思路过程如下:
这里写图片描述

参考代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
#define MME(a) memset(a,0,sizeof(a))
using namespace std;
int book[1005];//记录改点是否走过
int dp[1005];//记录1到任意节点的距离
int path[1005][1005];//记录两点之间的距离
int main()
{
    int t, n;
    while (~scanf("%d %d", &t, &n))
    {
        MME(book);
        MME(dp);
        MME(path);
        for (int i = 1;i <= n;i++)
        {
            for (int j = 1;j <= n;j++)
            {
                if (i == j)//由于不能自环,所以主对角线置零
                    path[i][j] = 0;
                else
                    path[i][j] = INF;
            }
        }
        for (int i = 1;i <= t;i++)
        {
            int st, ed, len;
            scanf("%d %d %d", &st, &ed, &len);
            /*坑点:需要考虑两点重复输入更新*/
            path[st][ed] = path[ed][st] = min(path[st][ed], len);
        }
        for (int i = 1;i <= n;i++)
        {
            dp[i] = path[1][i];/*dp数组存储1到任意节点的距离,如果没有关系就是正无穷*/
        }
        book[1] = 1;
        int pos = 0;
        for (int i = 1;i <= n-1;i++)
        {
            int min = INF;
            for (int j = 1;j <= n;j++)
            {
                /*如果改点没走过,且1到该节点为最短距离时*/
                if (!book[j] && dp[j] < min)
                {
                    min = dp[j];
                    pos = j;
                }
            }
            book[pos] = 1;
            /*说明1到该节点的距离已为最短,然后标记上*/
            for (int k = 1;k <= n;k++)
            {
                if (path[pos][k] != INF)/*如果pos到k有关系*/
                {
                    /*判断1直接到k点和1点到pos点再由pos点到k点谁距离短,然后赋值*/
                    if (dp[k] > dp[pos] + path[pos][k])
                        dp[k] = dp[pos] + path[pos][k];
                }
            }
        }
        printf("%d\n", dp[n]);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值