poj1426Find The Multiple(bfs ohohoh ~~~~好害怕)

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26508 Accepted: 10977 Special Judge

Description

Given a positive (积极的) integer (整数) n, write a program to find out a nonzero multiple m of n whose decimal (小数) representation (代表) contains only the digits (数字) 0 and 1. You may assume (承担) that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input (投入) file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates (终止) the input.

Output

For each value of n in the input (投入) print a line containing the corresponding value of m. The decimal (小数) representation (代表) of m must not contain more than 100 digits (数字). If there are multiple solutions (解决方案) for a given value of n, any one of them is acceptable (可接受的).

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source


#include<stdio.h>
#include<queue>
using namespace std;
int n;
long long int x;
void bfs()
{
    queue<long long int>q;
    q.push(1);

    while(!q.empty())
    {
      x=q.front();
      q.pop();
      if(x%n==0)
      {
          printf("%lld\n",x);
          break;
      }

      q.push(x*10);
      q.push(x*10+1);
    }
}
int main()
{

   while(~scanf("%d",&n),n)
   {
       bfs();
   }


}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值