动态规划 Sumsets

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
Input
A single line with a single integer, N.
Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
Sample Input
7

Sample Output

6


1.可以通过查找规律发现:

   

n:                                                     ans:

    1                                                          1

    2                                                          2

    3                                                          2

    4                                                          4

    5                                                          4

    6                                                          6

    7                                                          6

    8                                                          10

    9                                                          10

    10                                                        14

    11                                                        14

    12                                                         20

     ......                                                        ......

if(n%2!=0)                                                       a[n]=a[n-1]

if(n%2==0)                                               a[n]=a[n-2]+a[n/2];


2. 因为有这个公式 a[n]=a[n-2]+a[n/2];,所以n满足大于等于2,故而,要对a[0],a[1]初始化。

#include <iostream>

#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
#define MOD 1000000000;
int a[1000010];
void init()
{
    a[0]=a[1]=1;
    for(int i=2;i<1000010;i++)
    {
        if(i%2)
 a[i]=a[i-1];
        else
        {
            a[i]=a[i-2]+a[i/2];
            a[i]%=MOD;
        }
    }
}
int main()
{
    init();
    int n;
    cin>>n;
    printf("%d\n",a[n]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值