QS Network-ZOJ1586

QS Network-
In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS’s have received the message.
A sample is shown below:

A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.
Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS’s favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input
The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS’s favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.
Constrains:
all the integers in the input are non-negative and not more than 1000.

Output
for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input
1
3
10 20 30
0 100 200
100 0 300
200 300 0

Sample Output
370

题意:
QS是一种生物,要完成通信,需要设备,每个QS需要的设备的价格不同,并且,这种设备只能在两个QS之间用一次,也就是说,如果一个QS需要和3个QS通信的话,它就必须得买3个设备,同时,对方三个也必须买对应的适合自己的设备。同时,每两个QS之间是有距离的,要完成通信还需要网线,给出每两个QS之间的网线的价值。求一棵生成树,使得所需要的费用最少。
分析:
求一棵最小生成树,每两个之间的总代价为网线价值加两个设备的价值。
由于每两个之间都可以连接,所以是一个稠密图,所以选择用Prim算法,而不用kruskal算法

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

int E[1010][1010];
int price[1010];
int lowcost[1010];
int n;
int INF = 1010;


void init()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&price[i]);
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            scanf("%d",&E[i][j]);
            if(i==j)
                E[i][j]=INF;
            else
                E[i][j]+=price[i]+price[j];
        }
    }
}

void prim()
{
    int sum=0;
    lowcost[0]=-1;
    for(int i=1;i<n;i++)
        lowcost[i]=E[0][i];
    for(int i=1;i<n;i++)
    {
        int min=INF,j;
        for(int k=0;k<n;k++)
        {
            if(lowcost[k]!=-1 && min>lowcost[k])
            {
                min=lowcost[k];
                j=k;
            }
        }
        sum+=min;
        lowcost[j]=-1;
        for(int k=0;k<n;k++)
        {
            if(E[j][k]<lowcost[k])
            {
                lowcost[k]=E[j][k];
            }
        }
    }
    printf("%d\n",sum);
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        prim();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值