(HDU 5783)Divide the Sequence <思维水题> 多校训练5

41 篇文章 0 订阅
14 篇文章 0 订阅

Divide the Sequence
Problem Description
Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.

Input
The input consists of multiple test cases.
Each test case begin with an integer n in a single line.
The next line contains n integers A1,A2⋯An.
1≤n≤1e6
−10000≤A[i]≤10000
You can assume that there is at least one solution.

Output
For each test case, output an integer indicates the maximum number of sequence division.

Sample Input
6
1 2 3 4 5 6
4
1 2 -3 0
5
0 0 0 0 0

Sample Output
6
2
5

Author
ZSTU

Source
2016 Multi-University Training Contest 5

题意:
有一个大小为n的整型数组。现在要将他分成尽可能多的连续的子序列,满足每一子序列的所有前缀后大于等于0,问你最多可以分为多少个?

分析:
搞不清楚题目为什么要给2.5秒。。。
直接从后往前少一遍,若a[i]>=0 则将它单独分为一个子序列,若a[i]<0,则为使所有的前缀后>=0,那么我们要将以a[i]结尾的连续的一段和>=0的部分分为一个子序列即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
using namespace std;

const int maxn = 1e6 + 10;
int a[maxn];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int ans = 0;
        long long res = 0;
        for(int i=n;i>=1;)
        {
            res = res + a[i];
            if(res >= 0)
            {
                ans++;
                i--;
                res = 0;
            }
            else
            {
                while(res < 0)
                {
                    res = res + a[--i];
                }
                ans++;
                i--;
                res = 0;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值