hdu4496 D-City 判断两元素是否在同一集合

Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly. Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
Sample Input
5 10 
0 1 
1 2 
1 3 
1 4 
0 2 
2 3 
0 4 
0 3 
3 4 
2 4
Sample Output

1

1

1

2

2

2

2

3

4

5






思路:从输入的m条边倒着数,
若删完,结果应为n。
从下往上,添加边,若两点不在一个集合中,结果--;

注意:题目没说是一组还是多组用例,这就很尴尬了。
经测验是多组用例。。。。
还有注意数组越界问题,题目n,m范围,以及城市编号是从0到n-1

#include <cstdio>
#include <algorithm>
#define N 10005
#define M 100050

using namespace std;

int n, m;
int a[M], b[M];
int ans[M];
int f[N];

void init()
{
	for (int i = 0; i < n; i++)
		f[i] = i;
}

int find(int x)
{
	return x == f[x] ? x : f[x] = find(f[x]);
}

int merge(int x, int y)
{
	int t1, t2;
	t1 = find(x); t2 = find(y);
	if (t1 != t2)
	{
		f[t2] = t1;
		return 1;
	}
	return 0;
}

int main()
{
	while (scanf("%d%d", &n, &m) != EOF)
	{
		for (int i = 0; i < m; i++)
			scanf("%d%d", &a[i], &b[i]);
		init();
		int tmp = n;
		for (int i = m - 1; i >= 0; i--)
		{
			ans[i] = tmp;
			if (find(a[i]) != find(b[i]))//当前两城镇不连通
				tmp--;
			merge(a[i], b[i]);//连接两城镇
		}
		for (int i = 0; i < m; i++)
			printf("%d\n", ans[i]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值