HDU-1087-Java实现

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45178    Accepted Submission(s): 20951


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
 
 
3 1 3 24 1 2 3 44 3 3 2 10
 
Sample Output
 
 

4103


最大递增字段和,算是dp最最基本的题目了,你很难找个dp题目比这个题目简单的了,适合入门

import java.util.Scanner;
public class pro1087 {

	public static void main(String[] args) {
		// TODO 自动生成的方法存根
     Scanner cin=new Scanner(System.in);
     while(cin.hasNext())
     {
    	 int N=cin.nextInt();
    	 if(N==0)break;
    	 int num[]=new int[N];
    	 int dp[]=new int [N];
    	 for(int i=0;i<N;i++)
    	 {
    		 num[i]=cin.nextInt();
    		 dp[i]=num[i];
    	 }
    	 
    	 for(int i=0;i<N;i++)
    	 { 		 
    		 for(int k=0;k<i;k++)
    		 {
    			 if(num[k]<num[i])
    			 {   				
    				 dp[i]=Math.max(dp[i],dp[k]+num[i]);
    			 }
    				 
    		 }
    	 }
    	 int max=dp[0];
    	 for(int i=0;i<N;i++)
    	 {
    		 max=Math.max(max, dp[i]);
    		
    	 }
    	 System.out.println(max);
     }
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值