POJ-3262-Protecting the Flowers

Problem F

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 17   Accepted Submission(s) : 3
Problem Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

 

Input
Line 1: A single integer <i>N</i><br>Lines 2..<i>N</i>+1: Each line contains two space-separated integers, <i>T<sub>i</sub></i> and <i>D<sub>i</sub></i>, that describe a single cow's characteristics
 

Output
Line 1: A single integer that is the minimum number of destroyed flowers
 

Sample Input
 
 
6 3 1 2 5 2 3 3 2 4 1 1 6
 

Sample Output
 
 
86
 

题意:  约翰留下他的N只奶牛上山采木.他离开的时候,她们像往常一样悠闲地在草场里吃草.可是,当他回来的时候,他看到了一幕惨剧:牛们正躲在他的花园里,啃食着他心爱的美丽花朵!为了使接下来花朵的损失最小,约翰赶紧采取行动,把牛们送回牛棚. 牛们从1到N编号.第i只牛所在的位置距离牛棚Ti(1≤Ti《2000000)分钟的路程,而在约翰开始送她回牛棚之前,她每分钟会啃食Di(1≤Di≤100)朵鲜花.无论多么努力,约翰一次只能送一只牛回棚.而运送第第i只牛事实上需要2Ti分钟,因为来回都需要时间.    写一个程序来决定约翰运送奶牛的顺序,使最终被吞食的花朵数量最小.

思路:

二个牛中 A,B,属性分别为分别为eatA,timeA,eatB,timeB
选A的时候损失timeA*eatB
选B的时候损失timeB*eatA
双方同除以eatA*eatB.
令time/eat为一个羊的比率x
可以证明x小的那个为最优解.

#include<iostream>
#include<algorithm>
using namespace std;
struct cows
{
	int t;
	int d;
}a[100000];
int comp(cows a, cows b)
{
	return (a.t*1.0 / a.d) <(b.t*1.0 / b.d);
}
int main()
{
	int n;
	while (cin>>n)
	{
		long long int now = 0;
		int ans=0;
		for (int i = 1; i <= n; i++)
		{
			cin >> a[i].t >> a[i].d;
			now += a[i].d;
		}
		sort(a+1, a + n+1, comp);
		for (int i = 1; i <n; i++)
		{
			now -= a[i].d;
			ans += 2*now * a[i].t;
		}
		cout << ans << endl;
	}
	system("pause");
	return  0;

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值