1010 Radix

1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

 

#include <bits/stdc++.h>
using namespace std;
int main()
{
	string n1,n2;
	int tag,radix;
	long long sum1=0,sum2=0;
	vector <int> v[3];
	cin>>n1>>n2>>tag>>radix;
	for(int i=0;i<n1.length();i++)
	{
		if(isdigit(n1[i]))
			v[1].push_back(n1[i]-'0');
		else
			v[1].push_back(n1[i]-87);
	}
	for(int i=0;i<n2.length();i++)
	{
		if(isdigit(n2[i]))
			v[2].push_back(n2[i]-'0');
		else
			v[2].push_back(n2[i]-87);
	}
	int flag=1;
	int k;
	if(tag==1)
		k=2;
	else
		k=1;
	for(int i=v[tag].size()-1;i>=0;i--)
	{
		sum1+=v[tag][i]*pow(radix,v[tag].size()-1-i);
	}
	long long low=*max_element(v[k].begin(),v[k].end())+1;
	long long high=max(low,sum1);
	while(low<=high)
	{
		sum2=0;
		long long mid=(low+high)/2;
		for(int j=v[k].size()-1;j>=0;j--)
		{
			sum2+=v[k][j]*pow(mid,v[k].size()-1-j);
		}
		if(sum2<0||sum2>sum1)
			high=mid-1;
		else if(sum2<sum1)
			low=mid+1;
		else
		{
			flag=0;
			cout<<mid;
			break;
		}
	}
	if(flag==1)
		cout<<"Impossible";
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值