poj2253 dijsktra变形

 

 

如题:http://poj.org/problem?id=2253

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27725 Accepted: 9016

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

 

 

题意:给出n个坐标(x,y),一只青蛙从1号坐标跳2号坐标,问这其中所有的可行路径中的最大的一条边最小值。

 

思路:最短路,只不过改了松弛条件,要求的是所有路径中某个路径最大的边最小。dist[i]数组用来存储从源点到i号顶点的路径中的最大权边。

因此松弛的时候就是如果if(!vis[j] && dist[j]>Max(dist[minv],dis(t[minv],t[j]))){
    dist[j]=Max(dist[minv],dis(t[minv],t[j]));

应该很容易理解。

WA了一下午,最后发现dij()函数的return在for循环内,气死我。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
using namespace std;
#define MAXN 205
#define INF 0x0fffffff
#define Max(a,b)(a>b?a:b)

int n;
struct node
{
 int x,y;
 node(){}
 node(int a,int b):x(a),y(b){}
}t[MAXN];
double map[MAXN][MAXN];
double dist[MAXN];
int path[MAXN];
double dis(node a,node b)
{
 return sqrt(double((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)));
}
double dij()
{
 int i,j;
 int vis[MAXN]={0};
 for(i=1;i<=n;i++)
  dist[i]=dis(t[1],t[i]);
 dist[1]=0;
 vis[1]=1;
 for(i=1;i<=n;i++)
 {
  int minv;
  double mincost=INF;
  for(j=1;j<=n;j++)
   if(!vis[j]&&mincost>dist[j])
   {
    mincost=dist[j];
    minv=j;
   }
  vis[minv]=1;
   for(j=1;j<=n;j++)
   if(!vis[j] && dist[j]>Max(dist[minv],dis(t[minv],t[j]))){
    dist[j]=Max(dist[minv],dis(t[minv],t[j]));
   }
 }
   return dist[2];
}

int main()
{
// freopen("C:\\1.txt","r",stdin);
 int anli=0;
 while(~scanf("%d",&n))
 {
  anli++;
  if(!n)
   break;
  int i;
  memset(t,0,sizeof(t));
  for(i=1;i<=n;i++)
   scanf("%d%d",&t[i].x,&t[i].y);
  double res=dij(); 

  printf("Scenario #%d\nFrog Distance = %.3lf\n\n",anli,res);
 }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值