1009 Product of Polynomials

This time, you are supposed to find A × B A×B A×B where A A A and B B B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K , N 1 ​ ​ , a ​ N ​ 1 ​ ​ ​ ​ , N 2 a ​ N ​ 2 , . . . , ​ ​ ​ ​ N K a ​ N ​ K K, N_1​​, a_{​N​_1}​​​​, N_2a_{​N​_2}, ... , ​​​​N_Ka_{​N​_K} K,N1,aN1,N2aN2,...,NKaNK

where K K K is the number of nonzero terms in the polynomial, N i N_i Ni​​ and a ​ N ​ i a_{​N​_i} aNi​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10 , 0 ≤ N K ​ ​ &lt; ⋯ &lt; N ​ 2 ​ ​ &lt; N ​ 1 ​ ​ ≤ 1000 1≤K≤10,0≤N_K​​&lt;⋯&lt;N​_2​​&lt;N​_1​​≤1000 1K100NK<<N2<N11000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6


题解:

对于多项式乘积问题,如果采用数组存储则可能导致过于稀疏,对空间和时间都是极大的浪费,所以此处采用链表方式来存储 A A A,对于乘积结果 m u t i l mutil mutil 可直接用数组存储,方便同级项相加;
需要注意的是,对于数组 m u t i l mutil mutil ,其下标上限应为 A , B A,B A,B 两多项式乘积中的最大级数,此题中为 2001;


注意:

请熟练掌握链表的初始化与构建;


#include <iostream>
#include <cstdlib>
#include <iomanip>
using namespace std;

typedef struct PolyNode *Polynomial;
struct PolyNode {
	int exp;
	double coef;
	Polynomial next;
};

int main()
{
    Polynomial A, Next, Temp;
	A = (Polynomial)malloc(sizeof(struct PolyNode));
	A->next = NULL;
	Next = A;
	double mutil[2001] = {0};

	int n;
	int exp; double coef;
	// 读入 A
	cin >> n;
	while (n--) {
		Temp = (Polynomial)malloc(sizeof(struct PolyNode));
		cin >> exp >> coef;
		Temp->exp = exp;
		Temp->coef = coef;
		Temp->next = NULL;
		Next->next = Temp;
		Next = Temp;		//带有头节点
	}
	// 释放空节点
	Temp = A;
	A = A->next;
	free(Temp);

	// 读入 B,同时进行相乘相加
    cin >> n;
	while (n--) {
		cin >> exp >> coef;
		Temp = A;
		while(Temp){
            mutil[Temp->exp + exp] += Temp->coef * coef;
            Temp = Temp->next;
		}
	}
	int cont = 0;
	for(int i=0;i<2001;i++){
        if(mutil[i]!=0){
            cont++;
        }
	}
	cout<<cont;
	for(int i=2000;i>=0;i--){
        if(mutil[i]!=0){
            cout<<" "<<i<<" "<<fixed<<setprecision(1)<<mutil[i];
        }
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值