POJ 2406 Power Strings

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

 

题意:找最短循环子串循环的次数

思路:这里需要了解KMP的nex[]用法,这篇博客讲的很棒https://blog.csdn.net/v_july_v/article/details/7041827       

           等有机会我把关于我对这个知识点的理解写到博客里,主要队友们写的都太好了,所以这篇博客大概率咕。

           这道题需要知道的一个定理。下面先说定理,最后给证明。

      假设字符串S的长度为len,S存在循环子串,当且仅当 len%(len-nex[len])==0时,最短循环子串为S[ len-nex[len] ] .

    定理就一句话十分简便,下面我来说说怎么证明。

所以上述字符串最短循环子串为S1S2S3,长度为3,那么最短循环次数就是len/(len-nex[len])

 

AC代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define MAXN 1000017
using namespace std;
int nex[MAXN];
int len;
void getnext( char T[])
{
    int i = 0, j = -1;
    nex[0] = -1;
    while(i < len)
    {
        if(j == -1 || T[i] == T[j])
        {
            i++,j++;
            nex[i] = j;
        }
        else
            j = nex[j];
    }
}
 
int main()
{
    char ss[MAXN];
    int length;
    while(~scanf("%s",ss))
    {
        if(ss[0] == '.')
            break;
        len = strlen(ss);
        getnext(ss);
        length = len - nex[len];
        if(len%length == 0)
            printf("%d\n",len/length);
        else
            printf("1\n");
    }
    return 0;
}

 

有问题欢迎留言

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值