hdu 1498 50 years, 50 colors(最小顶点覆盖)

20 篇文章 0 订阅

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1160    Accepted Submission(s): 612


Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.


 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 

Sample Input
  
  
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output
  
  
-1 1 2 1 2 3 4 5 -1


 

题意:又一个n*n的矩阵,每个元素是一个气球的颜色,给出k次操作,每次操作可以选择把同一行或同一列的颜色相同的气球去掉,问经过k次之后无法去掉的颜色有什么。

思路:最小顶点覆盖。枚举每一种颜色求最大匹配数,若求得的最大匹配数>k,则经过k次之后该种颜色无法去掉。

 

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <cstdlib>
using namespace std;

const int maxn=105;
int match[maxn];
int map[maxn][maxn],color[maxn],ans[maxn];
bool vis[maxn];
int n,k,cnt1,cnt2;
bool find(int x,int k)
{
    for(int i=1;i<=n;i++)
    if(!vis[i]&&map[x][i]==k)
    {
        vis[i]=true;
        if(match[i]==-1||find(match[i],k))
        {
            match[i]=x;
            return true;
        }
    }
    return false;
}
int MMG(int k)
{
    int sum=0;
    memset(match,-1,sizeof(match));
    for(int i=1;i<=n;i++)
    {
        memset(vis,false,sizeof(vis));
        if(find(i,k)) sum++;
    }
    return sum;
}
int main()
{
   while(scanf("%d%d",&n,&k),n||k)
   {
       memset(vis,false,sizeof(vis));
       cnt1=0;
       for(int i=1;i<=n;i++)
       for(int j=1;j<=n;j++)
       {
           scanf("%d",&map[i][j]);
           if(!vis[map[i][j]])
           {
               color[cnt1++]=map[i][j];
               vis[map[i][j]]=true;
           }
       }
       cnt2=0;
       for(int i=0;i<cnt1;i++)
       {
           if(MMG(color[i])>k)
           ans[cnt2++]=color[i];
       }
       if(cnt2==0)
       printf("-1\n");
       else
       {
           sort(ans,ans+cnt2);
           for(int i=0;i<cnt2-1;i++)
           printf("%d ",ans[i]);
           printf("%d\n",ans[cnt2-1]);
       }
   }
   return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值