POJ1182 -- 食物链 并查集扩展域做法

食物链

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 116112 Accepted: 35343
Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。
Input

第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。
Output

只有一个整数,表示假话的数目。
Sample Input

100 7
1 101 1
2 1 2
2 2 3
2 3 3
1 1 3
2 3 1
1 5 5
Sample Output

3
Source

Noi 01

题目大意

题目思路

一般的并查集用一个点储存一个物体的信息(根),此题当中每个动物都有天敌与食物,我们可以将一个点拆分成三个点来分别存储动物本身的根、天敌的根和食物的根,最后所有的点的关系形成三棵树。输入时判断是否与之前的信息冲突或与题目条件2、3冲突就行了。

AC代码

#include <iostream>
#include <cstdio>
using namespace std;

int s[150010];
int height[150010] = {0};

int find_set(int x) {
	if (x == s[x]) return x;
	while (x != s[x])return s[x] = find_set(s[x]);//路径压缩
}
void union_set(int a, int b) {
	int roota = find_set(a);
	int rootb = find_set(b);
	if (roota != rootb) {
		if (height[roota] == height[rootb]) {//合并优化
			s[rootb] = s[roota];
			height[roota]++;
		}
		else if (height[roota] < height[rootb]) {
			s[roota] = s[rootb];
		}
		else {
			s[rootb] = s[roota];
		}
	}
}
int main() {
	int n, k;
	int d, x, y;
	int ans = 0;
	int xself, xsw, xtd, yself, ysw, ytd;
	scanf("%d%d", &n, &k);
	for (int i = 1; i <= 3 * n; ++i) {
		s[i] = i;
	}
	for (int i = 1; i <= k; ++i) {
		scanf("%d%d%d", &d, &x, &y);
		if (x > n || y > n || (d == 2 && x == y)) {//与条件2、3冲突
			ans++;
			continue;
		}
		if (x == y)continue;
		xself = x * 3 - 2; xsw = x * 3 - 1; xtd = x * 3;
		yself = y * 3 - 2; ysw = y * 3 - 1; ytd = y * 3;
		xself = find_set(xself); xsw = find_set(xsw); xtd = find_set(xtd);
		yself = find_set(yself); ysw = find_set(ysw); ytd = find_set(ytd);
		if (d == 1) {
			if (xself == yself)continue;
			if (xsw == yself || xtd == yself) {//如果xself是yself的天敌或yself是xself的天敌
				ans++;
			}
			else {
				union_set(xself, yself);
				union_set(xsw, ysw);
				union_set(xtd, ytd);
			}
		}
		else {
			if (xsw == yself)continue;
			if (xsw == ytd || xsw == ysw) {//xself和yself同类或yself是xself的天敌
				ans++;
			}
			else {
				union_set(xself, ytd);
				union_set(xsw, yself);
				union_set(xtd, ysw);
			}
		}
	}
	cout << ans << endl;

	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值