贪心-A

这个题和贪心算法好像没有关系。。。

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise. FJ’s N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

Input

  • Line 1: N

  • Lines 2…N+1: The location of each cow (in the range 0…1,000,000,000).

Output

There are five cows at locations 1, 5, 3, 2, and 4.

Sample Input

5
1
5
3
2
4

Sample Output

40

Hint

INPUT DETAILS:

There are five cows at locations 1, 5, 3, 2, and 4.

OUTPUT DETAILS:

Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) =40.

题意是在坐标轴上有n头牛,他们分别向其他牛moo叫。知道牛的位置,求它们声音的总距离。(其实就是求两数的差并把这些差加起来)。先将这些坐标排序,在计算出距离。以输入样例为例可以列出:
坐标:
1 2 3 4 5
距离:
0 1 2 3 4
1 0 1 2 3
2 1 0 1 2
3 2 1 0 1
4 3 2 1 0
容易发现这个矩阵的规律,于是想用双重循环做,于是果不其然超时了。。。最后的代码如下

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    long long int location[10010];
    long long int moo[10010];
    long long int a[10010];
    long long int sum=0;
    cin>>n;
    for(int i=1;i<=n;i++)
    cin>>location[i];
    sort(location+1,location+n+1);
    for(int i=1;i<=n;i++)
    a[i]=location[i+1]-location[i];
    for(int i=n-1,j=1;i>=1;i--,j++)
    {
       moo[j]=moo[j-1]+j*a[i];
       sum+=moo[j];
    }
    cout<<sum*2<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值