贪心-J

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

输入n门课作业的截止时间和所罚的分数,求最小的罚分是多少。
按照成绩从高到低排序,最高的刚好在截止日期那一天交,如果截止日期被占用,则往前推一天交,一次类推,如果到第一天都被占用,则跳出循环,输出没有提交的成绩和。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct note
{
    int time;
    int score;
}a[1005];
bool cmp(note a,note b)
{
    if(a.score==b.score)
    return a.time>b.time;
    else
    return a.score>b.score;
}
int main()
{
    int t,n;
    int flag[1005];
    cin>>t;
    while(t--)
    {
        memset(flag,0,sizeof(flag));
        cin>>n;
        for(int i=0;i<n;i++)
        cin>>a[i].time;
        for(int j=0;j<n;j++)
        cin>>a[j].score;
        sort(a,a+n,cmp);
        int sum=0;
        for(int i=0;i<n;i++)//每一组数据都要进行判断
        {
            for(int j=a[i].time;j>0;j--)//从截止日期判断,如果没被占用就占用这一天,若是被占用则往前推一天
            {
                if(!flag[j])
                {
                    flag[j]=1;
                    break;
                }
                else if(j==1)//直到第一天都被占用,则输出该成绩
                {
                    sum+=a[i].score;
                }
            }
        }
        cout<<sum<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值