hdu 4932 Miaomiao's Geometry(思路,枚举)

Miaomiao's Geometry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1957    Accepted Submission(s): 477


Problem Description
There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length.

There are 2 limits:

1.A point is convered if there is a segments T , the point is the left end or the right end of T.
2.The length of the intersection of any two segments equals zero.

For example , point 2 is convered by [2 , 4] and not convered by [1 , 3]. [1 , 2] and [2 , 3] are legal segments , [1 , 2] and [3 , 4] are legal segments , but [1 , 3] and [2 , 4] are not (the length of intersection doesn't equals zero), [1 , 3] and [3 , 4] are not(not the same length).

Miaomiao wants to maximum the length of segements , please tell her the maximum length of segments.

For your information , the point can't coincidently at the same position.
 

Input
There are several test cases.
There is a number T ( T <= 50 ) on the first line which shows the number of test cases.
For each test cases , there is a number N ( 3 <= N <= 50 ) on the first line.
On the second line , there are N integers Ai (-1e9 <= Ai <= 1e9) shows the position of each point.
 

Output
For each test cases , output a real number shows the answser. Please output three digit after the decimal point.
 

Sample Input
  
  
3 3 1 2 3 3 1 2 4 4 1 9 100 10
 

Sample Output
  
  
1.000 2.000 8.000
Hint
For the first sample , a legal answer is [1,2] [2,3] so the length is 1. For the second sample , a legal answer is [-1,1] [2,4] so the answer is 2. For the thired sample , a legal answer is [-7,1] , [1,9] , [10,18] , [100,108] so the answer is 8.

题意:给x轴上几个点,求多个等长的线段(线段至少得有一个端点是给的点)能覆盖所有点,并且线段之间无相交(可以端点相交),问线段最长是多少?

思路:分析可知最终答案只能是两点间线段长度或者其一半,枚举即可。

证明:如果不考虑线段不能相交的话,答案就是所有点的最大合法长度里的最小值,一个点的最大合法长度就是左右能延伸到的最远距离

但是这样考虑不能相交,那么首先最终答案不可能<某个长度的½的一个值,因为如果这样,另一边也是这个值,那为什么不取½?

其次,举几个测试样例即可知道,最终答案不可能大于某个长度的½,无论怎样都会有一个长度满足两点间的整段距离

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 1000
double a[N],b[N],s[N];
int vis[N];
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%lf",&a[i]);
        sort(a,a+n);
        int cnt=0;
        for(int i=1; i<n; i++)
        {
            s[cnt++]=a[i]-a[i-1];
            s[cnt++]=(a[i]-a[i-1])/2;
        }
        sort(s,s+cnt);
        for(int i=cnt-1; i>=0; i--)
        {
            double len=s[i];
            for(int j=0; j<n; j++)
                b[j]=a[j];
            int flag=0;
            memset(vis,0,sizeof(vis));
            for(int j=1; j<n-1; j++)
            {
                if(vis[j]) continue;
                if(b[j]-b[j-1]>=len)
                    continue;
                else if(b[j+1]-b[j]>=len)
                {
                    b[j]=b[j]+len;
                    if(b[j]==b[j+1])
                        vis[j+1]=1;
                }
                else
                {
                    flag=1;
                    break;
                }
            }
            if(!flag)
            {
                printf("%.3lf\n",len);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值