hdu 5842 Lweb and String(水题)

Lweb and String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 207    Accepted Submission(s): 131


Problem Description
Lweb has a string  S .

Oneday, he decided to transform this string to a new sequence. 

You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing). 

You need transform every letter in this string to a new number.

A  is the set of letters of  S B  is the set of natural numbers. 

Every injection  f:AB  can be treat as an legal transformation. 

For example, a String “aabc”,  A={a,b,c} , and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3. 

Now help Lweb, find the longest LIS which you can obtain from  S .

LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)
 

Input
The first line of the input contains the only integer  T,(1T20) .

Then  T  lines follow, the i-th line contains a string  S  only containing the lowercase letters, the length of  S  will not exceed  105 .
 

Output
For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.
 

Sample Input
  
  
2 aabcc acdeaa
 

Sample Output
  
  
Case #1: 3 Case #2: 4
 

Author
UESTC
 

Source
题意:给你一个串求LIS,注意a不一定是最小的,根据他给的顺序。 比如 串是cbdc 那么转换过来是1231

思路:

看错题以为裸LIS,果断WA。

才发现是个更水的题T T

只要判断是否出现过,没出现过+1即可。LIS都可以省了

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 100050
char a[N];
int n;
int ans[N];
int main()
{
    int T,t,tot=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",a);
        int m=strlen(a);
        ans[1]=a[0]-'a';
        int len=1;
        for(int i=1; i<m; i++)
        {
            if(a[i]-'a'>ans[len])
                ans[++len]=a[i]-'a';
            else
            {
                int pos=lower_bound(ans+1,ans+1+len,a[i]-'a')-ans;///注意这个地方是减ans,长度要从1开始
                ans[pos]=a[i]-'a';
            }
        }
        printf("Case #%d: %d\n",tot++,len);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值