a1118 Birds in Forest(并查集,set)

1118 Birds in Forest (25 分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤104) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B1​ B2​ ... BK​

where K is the number of birds in this picture, and Bi​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (≤104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

题意:给出n张照片,照片都是拍的某棵树一个部分,每张照片有k只鸟, 问有多少棵树,多少只鸟。

思路:并查集,多少棵树就是求有多少个父亲,多少只鸟求个容量就好了。每一只鸟都放在一个集合中,最后集合的大小就是鸟的数量,然后集合清空,找父亲的数量,每个父亲都插入集合中,这时集合的数量就是树的数量。

反思:刚开始没有路径压缩,一直有个测试点超时,最后路径压缩,就通过了。

#include <iostream>
#include "set"
using namespace std;
int father[10010];
void init(){
    for (int i = 0; i < 10010; ++i) {
        father[i]=i;
    }
}
int find(int x){
    int a=x;
    while (father[x]!=x){
        x=father[x];
    }
    while (a!=father[a]){
        int z=a;
        a=father[a];
        father[z]=x;
    }
    return x;
}
void Union(int a,int b){
    int fa= find(a);
    int fb= find(b);
    if (fa != fb){
        father[fa]=fb;
    }
}
int main() {
    int n,k,b,id;
    scanf("%d",&n);
    init();
    set<int> cc;
    for (int i = 0; i < n; ++i) {
        scanf("%d%d",&k,&id);
        cc.insert(id);
        for (int j = 0; j < k-1; ++j) {
            scanf("%d",&b);
            cc.insert(b);
            Union(id,b);
        }
    }
    int len=cc.size();
    cc.clear();
    for (int i = 1; i <= len; ++i) {
            cc.insert(find(i));

    }
    printf("%d %d\n",cc.size(),len);
    int qurys;
    scanf("%d",&qurys);
    for (int i = 0; i < qurys; ++i) {
        int d,c;
        scanf("%d%d",&d,&c);
        if (father[d]!= father[c]) cout<<"No"<<endl;
        else cout<<"Yes"<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值