1117 Eddington Number-PAT甲级

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

根据题意可知求解最大的k,满足有k天的骑行距离大于等于k,用二分查找法即可求得k

注意在求解的时候答案不一定为输入的数字,比下一个数小1即可

满分代码如下: 

#include<bits/stdc++.h>
using namespace std;
const int N=100010;
int dst[N];
int n;
int main(){
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>dst[i];
	}
	sort(dst,dst+n);
	int max_num=-1,v=0,h=-1;
	for(int i=0;i<n;i++){
		int k=upper_bound(dst,dst+n,dst[i])-dst;
		k=n-k;
		if(k>=dst[i]&&dst[i]>=max_num){
			max_num=dst[i];
			h=i;
		}
	}
	cout<<dst[h+1]-1<<endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值