1117 Eddington Number (25分)
British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.
Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.
Output Specification:
For each case, print in a line the Eddington number for these N days.
Sample Input:
10
6 7 6 9 3 10 8 2 7 8
Sample Output:
6
题⽬目⼤大意:英国天⽂文学家爱丁顿很喜欢骑⻋车。据说他为了了炫耀⾃自⼰己的骑⻋车功⼒力力,还定义了了⼀一个“爱丁顿 数”E,即满⾜足有E天骑⻋车超过E英⾥里里的⼤大整数E。据说爱丁顿⾃自⼰己的E等于87。
分析:在数组a中存储n天的公⾥里里数,对n个数据从⼤大到⼩小排序,i表示了了骑⻋车的天数,那么满⾜足a[i] > i+1 的⼤大i+1即为所求
#include<bits/stdc++.h>
using namespace std;
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int n;
cin>>n;
vector<int>t(n);
for(int i=0; i<n; i++)
cin>>t[i];
sort(t.begin(),t.end(),cmp);
int e=0;
while(e<n&&t[e]>e+1)e++;
cout<<e<<endl;
return 0;
}