HDU ACM1165——Eddy's research II

41 篇文章 0 订阅
34 篇文章 0 订阅

Eddy’s research II

Problem Description

As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:
这里写图片描述

Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).

Input

Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24.
Input is terminated by end of file.

Output

For each value of m,n, print out the value of A(m,n).

Sample Input

1 3
2 4

Sample Output

5
11

这道题看起来你只要按它所给函数关系写一个函数即可,但如果你真的这么写的话必然会超时。所以这就又需要我们来总结规律了。而m的值只有0,1,2,3,所以可以分这几种情况讨论,寻找规律。

#include<stdio.h>
int A( int m , int n )
{
    if( n == 0 )
        A( m - 1 , 1 ) ;
    else if( m == 0 || m == 1 )
        return n + 2;
    else if( m == 2 )
        return 2 * n + 3;
    else if( m == 3 )
        return A( m , n - 1 ) * 2 + 3;
}

int main()
{
    int m,n;
    while(scanf("%d %d",&m,&n)!=EOF){
        printf("%d\n",A(m,n));
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值