poj 3259 bellman最短路判断有无负权回路

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 36717 Accepted: 13438

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

70ms

#include<iostream>  //79ms
#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 10000000

using namespace std;

struct node
{
    int u,v,w;
} edge[5500];
int low[5500];
int n,m,z;
int num=0;
int Bellman()
{
    for(int i=0; i<=n; i++)
        low[i]=INF;

    for(int i=0; i<n-1; i++)
    {
        int flag=0;
        for(int j=0; j<num; j++)
        {
            if(low[edge[j].u]+edge[j].w<low[edge[j].v])
            {
                low[edge[j].v]=low[edge[j].u]+edge[j].w;
                flag=1;
            }
        }
        if(flag==0)  //存在负权回路
            break;
    }

    for(int j=0; j<num; j++)   //判断负权回路
    {
        if(low[edge[j].u]+edge[j].w<low[edge[j].v])
            return 1;
    }
    return 0;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&z);
        int a,b,c;
        num=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            edge[num].u=a;
            edge[num].v=b;
            edge[num++].w=c;

            edge[num].u=b;
            edge[num].v=a;
            edge[num++].w=c;
        }

        for(int i=1; i<=z; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            edge[num].u=a;
            edge[num].v=b;
            edge[num++].w=-c;
        }
        if(Bellman())
            printf("YES\n");
        else
            printf("NO\n");
    }
}



700ms

#include<iostream>  //挨个点遍历
#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 0x3f3f3f3f

using namespace std;

struct node
{
    int u,v,w;
} edge[5500];
int low[550];
int n,m,z;
int num=0;
int Bellman(int u0)
{
    for(int i=0; i<=n; i++)
        low[i]=INF;
    low[u0]=0;
    for(int i=0; i<n; i++)  //递推n次,让其构成环来判断
    {
        int flag=0;
        for(int j=0; j<num; j++)
        {
            if(low[edge[j].u]!=INF&&low[edge[j].u]+edge[j].w<low[edge[j].v])
            {
                low[edge[j].v]=low[edge[j].u]+edge[j].w;
                flag=1;
            }
        }
        if(flag==0)  //存在负权回路(减少时间)
            break;
    }
    if(low[u0]<0)
		return 1;
    return 0;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&z);
        int a,b,c;
        num=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            edge[num].u=a;
            edge[num].v=b;
            edge[num++].w=c;

            edge[num].u=b;
            edge[num].v=a;
            edge[num++].w=c;
        }

        for(int i=1; i<=z; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            edge[num].u=a;
            edge[num].v=b;
            edge[num++].w=-c;
        }
        int biao=1;
        for(int i=1; i<=n; i++)
        {
            if(Bellman(i))
            {
                printf("YES\n");
                biao=0;
                break;
            }
        }
        if(biao)
            printf("NO\n");
    }
}
/*
780ms
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 0x3f3f3f3f

using namespace std;

struct node
{
    int u,v,w;
} edge[5500];
int low[5500];
int n,m,z;
int num=0;
int Bellman(int u0)
{
    for(int i=0; i<=n; i++)             
        low[i]=INF;

    low[u0]=0;                         //初始化
    for(int i=0; i<n-1; i++)              //n-1次
    {
        int flag=0;
        for(int j=0; j<num; j++)
        {
            if(low[edge[j].u]!=INF&&low[edge[j].u]+edge[j].w<low[edge[j].v])   //不同点
            {                                          //存在low[edge[j].u]!=INF,就必须有low[u0]=0;初始化
                low[edge[j].v]=low[edge[j].u]+edge[j].w;
                flag=1;
            }
        }
        if(flag==0)  //存在负权回路
            break;
    }

    for(int j=0; j<num; j++)
    {
        if(low[edge[j].u]!=INF&&low[edge[j].u]+edge[j].w<low[edge[j].v])
            return 1;
    }
    return 0;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&z);
        int a,b,c;
        num=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            edge[num].u=a;
            edge[num].v=b;
            edge[num++].w=c;

            edge[num].u=b;
            edge[num].v=a;
            edge[num++].w=c;
        }

        for(int i=1; i<=z; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            edge[num].u=a;
            edge[num].v=b;
            edge[num++].w=-c;
        }
        int biao=1;
        for(int i=1; i<=n; i++)
        {
            if(Bellman(i))
            {
                printf("YES\n");
                biao=0;
                break;
            }
        }
        if(biao)
            printf("NO\n");
    }
}
*/


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值