Largest Submatrix of All 1’s----单调栈

Largest Submatrix of All 1’s
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 6455 Accepted: 2381
Case Time Limit: 2000MS

Description

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ mn ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4
题目链接:http://poj.org/problem?id=3494


  这个题的意思是说让你找出面积最大的全由1组成的矩形,算是我上一篇单调栈的一个加强版

http://blog.csdn.net/bless924295/article/details/69486449

我们可以从左往右把非0项加和,然后我们就会惊讶的发现,和上一个题差不多,如果我们把每一列看做一个底,然后就是上一个题了,条形图求最大矩形面积,然后我们就可以每一列都去跑一遍,取最大值就可以了。

代码:

/*
5 5
1 1 1 0 0
0 0 1 0 0
0 0 1 0 0
0 0 1 0 0
0 0 1 0 0
*/

#include <cstdio>
#include <cstring>
#include <iostream>
#include <stack>
using namespace std;
int a[2020][2020];
int L[2020];
int R[2020];
struct node{
    int num,h;
}xin[2020];
int solve(int n,int cnt){
    stack<struct node>s;
    for(int i=1;i<=n;i++){
        xin[i].h=a[i][cnt];
        xin[i].num=i;
    }
    xin[0].num=0;
    xin[0].h=0;
    n++;
    xin[n].num=n;
    xin[n].h=0;
    s.push(xin[0]);
    for(int i=1;i<=n;i++){
        if(xin[i].h>=s.top().h)
            s.push(xin[i]);
        else{
            while(s.top().h>xin[i].h)
            {
                struct node tmp=s.top();
                s.pop();
                R[tmp.num]=i;
                L[tmp.num]=s.top().num;
            }
            s.push(xin[i]);
        }
    }
    int ans=-1;
    for(int i=1;i<n;i++){
        ans=max(ans,xin[i].h*(R[i]-L[i]-1));
    }
    return ans;
}
int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                scanf("%d",&a[i][j]);
                if(a[i][j]){
                    a[i][j]+=a[i][j-1];
                }
             }
        }
        int ans=0;
        for(int j=1;j<=m;j++){
            ans=max(ans,solve(n,j));
        }
        printf("%d\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值