Mayor's posters POJ - 2528(线段树+离散化)

Mayor's posters

 POJ - 2528

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 

  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l iand ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

题意:T组案例,5张海报,海报的高度一样,按顺序给出5张海报的长度,求最后能看到几张。

思路:线段树,由后向前更新。unique函数:去重,但是重复的数并没有去掉,而是放在了数组的后面

ZOJ1610中建树时到 l+1==r就return,这里是到 l==r,不是特别理解, 觉得他俩题目没啥区别。。。求大佬指点。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 10010
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
#define MID(l,r) (l+(r-l)/2)
#define lson(o) (o<<1)
#define rson(o) (o<<1|1)
using namespace std;

struct pic  //海报
{
    int l,r;
}pics[maxn];
int x[maxn<<1];
int t[10000005];
struct node
{
    int l,r;
    bool cover;
}tree[maxn<<3];
void build(int o,int l,int r)
{
    tree[o].l = l;
    tree[o].r = r;
    tree[o].cover = 0;
    if(l == r) return ;
    int m = MID(l,r);
    int lc = lson(o),rc = rson(o);
    build(lc,l,m);
    build(rc,m+1,r);
}
bool update(int o,int l,int r)
{
    if(tree[o].cover == 1) return false;
    if(tree[o].l == l && tree[o].r==r){
        tree[o].cover = 1;
        return true;
    }
    bool flag;
    int m = MID(tree[o].l,tree[o].r);
    int lc = lson(o),rc = rson(o);
    if(r<=m) flag = update(lc,l,r);
    else if(l>m) flag = update(rc,l,r);
    else{
        bool f1 = update(lc,l,m);
        bool f2 = update(rc,m+1,r);
        flag  = f1||f2;
    }
    if(tree[lc].cover && tree[rc].cover){
        tree[o].cover = 1;
    }
    return flag;
}
int main()
{
    int T;
    int n;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        int k = 0;
        for(int i=1;i<=n;++i){
            scanf("%d %d",&pics[i].l,&pics[i].r);
            x[++k] = pics[i].l;
            x[++k] = pics[i].r;
        }
        sort(x+1,x+k+1);
        int cnt = unique(x+1,x+k+1)-x-1; //去重
        for(int i=1;i<=cnt;++i){
            t[x[i]] = i;
        }
        build(1,1,cnt);
        int ans = 0;
        for(int i=n;i>=1;--i){  //从上向下
            if(update(1,t[pics[i].l],t[pics[i].r]))
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值