zoj2100seeding(DFS)

Seeding

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO

题目大意:

Tom想把自己的地里播种完种子,条件是:(1)有石头的地方不能播种,(2)已经播种好的不能再播种,问汤姆最后能否将土地全部都种上种子;

解题思路:DFS搜索+回溯;(即当遇到不满足的的位置回溯到该位置的上一个位置然后从此位置向下一个可以走继续搜索直到所有的点都搜索到)

每走完一个位置就将其赋为“S”,并不断统计图中“S”(即石头)的个数cnt,如果有cnt == N*M(即图中所有未播种的位置都能播种)代表可以将土地上能播种的地方都种上;

否则就不可以;

#include<stdio.h>
#include<string.h>
char map[10][10];
int n,m,cnt,k;
void dfs(int x,int y)
{
    if(cnt==n*m)                  //可以都播种上,k = 1;
    {
    	k=1;
    	return;
	}
	if(x<0||x>=n||y<0||y>=m)    //判断是否越界;
	  return ;
	if(map[x][y]=='S')          //判断是否是石头或已种过;
	  return ; 
	cnt++;
	map[x][y]='S';
	dfs(x-1,y);
	dfs(x,y-1);
	dfs(x,y+1);
	dfs(x+1,y);
	cnt--;                 //当进入死角时;回溯到上一个位置;
	map[x][y]='.';

}
int main()
{
	int i,j;
	while(scanf("%d%d",&n,&m)&&(n|m))
	{
		cnt=0;k=0;
		memset(map,0,sizeof(map));
		for(i=0;i<n;i++)
		{
			getchar();
			for(j=0;j<m;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='S')         //记录初始图中"S"的个数;
				  cnt++;
			}
		}
	dfs(0,0);
	if(k==1)
	 printf("YES\n");
	else
	 printf("NO\n");
	}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值