hdu1010Tempter of the Bone(DFS)

22 篇文章 0 订阅

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 91096    Accepted Submission(s): 24769


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 
题目大意:
这个题目的意思是给定你起点S,和终点D,问你是否能在 T 时刻恰好到达终点D。
解题思路:
总体上用dfs求解,当如果不剪枝的话往往会超时;首先,当初始图中能走的点小于等于T时,一定走不到;一次剪枝。当要按T时间走时,能成功走到D的剩余时间
若小于从当前点到D点最短时间 abs(x-ex) + abs(y-ey);也一定走不到;还有就是奇偶剪枝。
奇偶剪枝:奇偶剪枝_百度百科
http://baike.baidu.com/link?url=ABUiQz9XuRVaSBOaiKUQJl90Wa94zIKjgYfNU_ocno3X4x5LlF53PWAaD1kuoDCrI-PRIVvt3qyZ0EKGddrrV_
奇偶剪枝:把map看作
0 1 0 1 0 1
1 0 1 0 1 0
0 1 0 1 0 1
1 0 1 0 1 0
0 1 0 1 0 1
 
从 0->1 需要奇数步
从 0->0 需要偶数步
那么设所在位置 (si,sj) 与 目标位置 (di,dj)
如果abs(si-sj)+abs(di-dj)为偶数,则说明 abs(si-sj) 和 abs(di-dj)的奇偶性相同,需要走偶数步
如果abs(si-sj)+abs(di-dj)为奇数,那么说明 abs(si-sj) 和 abs(di-dj)的奇偶性不同,需要走奇数步
理解为 abs(si-sj)+abs(di-dj) 的奇偶性就确定了所需要的步数的奇偶性!!
而 (t-cnt)表示剩下还需要走的步数,由于题目要求要在 t时 恰好到达,那么  (t-cnt) 与 abs(si-sj)+abs(di-dj) 的奇偶性必须相同
因此 temp=t-cnt-abs(sj-dj)-abs(si-di) 必然为偶数!
 
<span style="font-size:18px;"><pre name="code" class="objc">#include<cstdio>
#include<cstring>
#include<cmath>
int dx[]={-1,0,1,0};
int dy[]={0,-1,0,1};
char map[10][10];
int vis[10][10];
int n,m,t;
int ex,ey,sx,sy,flag;
void dfs(int x,int y,int tim)
{
   if(flag==1)
        return;
   if(tim==t)
   {   
   if(x==ex&&y==ey)
     flag=1;
   	return;
    }
   if((t-tim-abs(x-ex)-abs(y-ey))<0)  //t-tim是能成功逃脱的剩余的时间; 
     return;                          //abs(x-ex)+abs(y-ex)从当前点走距离D的最短距离(或时间);
	                                  //abs(x-ex)+abs(y-ey)>t-tim,表示不能按在T时走到; 
   if((t-tim-abs(x-ex)-abs(y-ey))%2!=0)  //奇偶剪枝 
    return;
   for(int i=0;i<4;i++)
   {
   int	a=x+dx[i];
   int	b=y+dy[i];
   	if(a>=0&&a<n&&b>=0&&b<m&&!vis[a][b]&&map[a][b]!='X')
   	{
   	   vis[a][b]=1;
	   dfs(a,b,tim+1);
	   vis[a][b]=0;	
	}	  
   }   	
}
int main()
{
	int i,j;
	int cnt;
	while(scanf("%d%d%d",&n,&m,&t)&&(n|m|t))
	{
		cnt=0;
		for(i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='S')
				{
					sx=i;sy=j;
				}
				if(map[i][j]=='D')
				{
					ex=i;ey=j;
				}
				if(map[i][j]=='X')
				 cnt++;
			}
		
		}
		if(n*m-cnt<=t)     //剪枝1 
		{
			printf("NO\n");
			continue;
		}
		memset(vis,0,sizeof(vis));
		flag=0;
		vis[sx][sy]=1;
		dfs(sx,sy,0);
		if(flag)
		 printf("YES\n");
		else
		 printf("NO\n");
	}
  return 0;
}</span>


 
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值