hdu1711Number Sequence(KMP)

6 篇文章 0 订阅

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16453    Accepted Submission(s): 7245


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 题目大意:给你两个数字序列a[]和b[],求b[]序列在a[]序列中最早发生匹配的位置,若不存在,输出-1.
简单的KMP,需要注意的是,由于是都是数字序列,每个数字范围不确定,这是不能当作字符来处理,所以a[]、b[]应定义为整型;
AC代码:
#include<stdio.h>
#include<string.h>
int a[1000100],b[10100];
int p[10010];
int n,m;
void getp()
{
	int i=0,j=-1;
	p[i]=j;
	while(i<m)
	{
		if(j==-1||b[i]==b[j])
		{
			i++,j++;
			p[i]=j;
		}
		else
		 j=p[j];
	}
}
int Kmp()
{
	int i=0,j=0,k=-1;;
	getp();
	while(i<n)
	{
		if(j==-1||a[i]==b[j])
		{
			i++,j++;
			if(j==m)
			{
				k=i;
				break;
			}	 
		}
		else
		 j=p[j];
	}
return k;
}
int main()
{
	int t;
	int i,j,x;
	scanf("%d",&t);
	while(t--)
	{
		memset(p,0,sizeof(p));
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
		{
			getchar();
			scanf("%d",&a[i]);	
		}
		for(i=0;i<m;i++)
		{
			getchar();
			scanf("%d",&b[i]);
		}
		x=Kmp();
		if(x<0)
		 printf("-1\n");
		else
		 printf("%d\n",x-m+1);
	}
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值