hdu1051Wooden Sticks(贪心)

18 篇文章 0 订阅

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15585    Accepted Submission(s): 6413


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
题目大意:有 n个长度为 L[i],重量为w[i]的木棒需要加工,每次第一个加工的木棒花费一分钟,若后面的木棒长度和重量都大于等于第一个加工的木棒,
则不耗费任何时间。问加工 n 个木棒最少需要多少木棒?
解题思路:最近搞了几个贪心,发现多个变量决定一个物体时,在排序时,这几个变量都要考虑,否则就一直wrong,看来看问题不能太片面啊;一看是两个参数长度和重量决定一个木棒,又要求最少时间,所以可以现按长度从小到大排序,当长度相等时,重量小的靠前。这样第一步搞定,再看题中的例子说
(1,4), (3,5), (4,9), (2,1), (5,2).这样排序后所用的时间是最短,且是2分钟。咋一看,感觉不对啊,(2,1)(5,2)这两个明明不符合条件,怎么可能两分钟,应该是三分钟啊。其实这是分两步进行的,第一次先把(1,4)(3,5)(4,9)加工完,需要一分钟,第二次在把(2,1)(5,2)弄完,需要一分钟。所以共需2分钟。
所以可知在排完序后应对其进行扫描,把第一次可以加工的扫描并标记,在弄剩余的并标记,直到所有都被加工完。能扫描几次就需要几分钟。
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct wooden{
	int x,y;
	int flag;	
}d[5010];
int cmp(wooden a,wooden b)
{
  if(a.x!=b.x)
	return a.x<b.x;
  else
    return a.y<b.y;
}
int main()
{
	int c;
	int n;
	int i,j,k,time;
	scanf("%d",&c);
	while(c--)
	{
		memset(d,0,sizeof(d));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&d[i].x,&d[i].y);
			d[i].flag=0;
		}
		sort(d,d+n,cmp);
		time=0; 
		for(i=0;i<n;i++)
		{
			if(!d[i].flag)
			{
				d[i].flag=1;
				for(j=i+1;j<n;j++)
				{
					if(!d[j].flag&&d[j].x>=d[i].x&&d[j].y>=d[i].y)
					{
						d[j].flag=1;
						d[i].x=d[j].x;
						d[i].y=d[j].y;
					}
				} 
				time++;
			}
		}	
	printf("%d\n",time);
	}
return 0;	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值