hdu4245A Famous Music Composer(水题)

43 篇文章 0 订阅

A Famous Music Composer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1126    Accepted Submission(s): 633


Problem Description
Mr. B is a famous music composer. One of his most famous work was his set of preludes. These 24 pieces span the 24 musical keys (there are musically distinct 12 scale notes, and each may use major or minor tonality). The 12 distinct scale notes are:


Five of the notes have two alternate names, as is indicated above with equals sign. Thus, there are 17 possible names of scale notes, but only 12 musically distinct notes. When using one of these as the keynote for a musical key, we can further distinguish between major and minor tonalities. This gives 34 possible keys, of which 24 are musically distinct.

In naming his preludes, Mr. B used all the keys except the following 10, which were named instead by their alternate names:


Write a program that, given the name of a key, give an alternate name if it has one, or report the key name is unique.
 

Input
Each test case is described by one line having the format "note tonality", where "note" is one of the 17 names for the scale notes given above, and "tonality" is either "major" or "minor" (quotes for clarify).
 

Output
For each case output the required answer, following the format of the sample.
 

Sample Input
  
  
Ab minor D# major G minor
 

Sample Output
  
  
Case 1: G# minor Case 2: Eb major Case 3: UNIQUE
 

题目大意:当输入的字符是第二表中的字符时,就是按第二个表格中字符对应着打印输出,否则就是输出“UNIQUE”。

代码:

#include<stdio.h>
#include<string.h>
struct str{
	char s1[3],s2[3];
}a[6];
int main()
{
	int i,j,k;
	char b1[3],b2[10];
	strcpy(a[0].s1,"A#"),strcpy(a[0].s2,"Bb");
	strcpy(a[1].s1,"C#");strcpy(a[1].s2,"Db");
	strcpy(a[2].s1,"D#");strcpy(a[2].s2,"Eb");
	strcpy(a[3].s1,"F#");strcpy(a[3].s2,"Gb");
	strcpy(a[4].s1,"G#");strcpy(a[4].s2,"Ab");
	k=1; 
	while(scanf("%s%s",b1,b2)!=EOF)
	{
		printf("Case %d: ",k++);
		int len=strlen(b1);
		if(len==1)
		 printf("UNIQUE\n");
		else
		{
			for(i=0;i<5;i++)
			{
				if(strcmp(b1,a[i].s1)==0)
				{
					printf("%s %s\n",a[i].s2,b2);
					break;
				}
				else if(strcmp(b1,a[i].s2)==0)
				{
				 printf("%s %s\n",a[i].s1,b2);
				 break;
		     	}
			}
		}
	}
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值