pojRed and Black(dfs)

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 27213 Accepted: 14782

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
题目大意:‘#’表示红方块,‘.’表示黑方块,某人初始位置在‘@',可以向上下左右四个方向走,他只能走黑块;问从起点他能走的黑块的个数共有多少?
解题思路:本体可以用深搜来解决;算是比较基础;主要思路就是从起点开始上下左右开始搜索,并不断将走过的黑块标记为红块,表示已走过;此过程定义一个全局变量来统计走过的黑块数;当所有可以走的黑块都被走一遍,搜索完毕。
AC代码:
//poj-1979dfs 
#include<stdio.h>
#include<string.h>
char map[30][30];
int n,m,sx,sy,cnt;
void dfs(int x,int y)
{
	if(x<0||x>=m||y<0||y>=n) return ;  //判断是否越界; 
	if(map[x][y]=='#') return ;        //红块不能走; 
	map[x][y]='#';
	cnt++;          //统计走过的黑块数 
	dfs(x-1,y);     //四个方向开始搜索 
	dfs(x+1,y);
	dfs(x,y+1);
	dfs(x,y-1);
}
int main()
{
   int i,j,k;
   while(scanf("%d%d",&n,&m)&&(n|m))
   {
   	 cnt=0;
   	 memset(map,0,sizeof(map));
     for(i=0;i<m;i++)	
     {
     	getchar();
     	scanf("%s",map[i]);
     	for(j=0;j<n;j++)
     	{
     		if(map[i][j]=='@'){
     			sx=i;sy=j;
			 }
		 }
	 }
	 dfs(sx,sy);
	 printf("%d\n",cnt);
   }
   return 0;	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值