并查集hdu4496

Description

Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 
Input

First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 
 
Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.
 
Sample Input

5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 
Sample Output

1 1 1 2 2 2 2 3 4 5
Hint

 The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 
connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes 
still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it 
became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number
of vertex, so the last output should always be N. 
         
  
题目描述:给出一个有N(0<N<=10000)个顶点的无向图,然后依次给出它的M(0<M<=100000)条边,要求依次输出当删除给出的前k(0<K<=M)条边后,该图的连通分量总数。

输入:第一行是N和M,然后是M行数(X,Y)(0<=X,Y<N)表示X与Y有边。

输出:依次输出所求的连通分量数。

 

分析:

        当删除前K条边时图所剩的连通分量数 就是 N个点孤立时只添加后M-K条边时,所具有的连通分量数。

        所以仅需倒序插入每条边,分别保存插入边后新图所具有的连通分量数目在数组内,然后输出数组即可。

#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=10000+5;
const int maxm=100000+5;
 
//并查集fa
int fa[maxn];
int findset(int x)
{
    return fa[x]==-1? x : fa[x]=findset(fa[x]);
}
int bind(int u,int v)
{
    int fu=findset(u);
    int fv=findset(v);
    if(fu!=fv)
    {
        fa[fu]=fv;
        return 1;//连通分量少了1个
    }
    return 0;
}
 
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)==2)
    {
        memset(fa,-1,sizeof(fa));
 
        //vc按序保存所有的边
        vector<pair<int,int> > vc;
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            vc.push_back(make_pair(x,y));
        }
 
        //保存连通分量数
        vector<int> res;
        int cnt=n;//当前连通分量数
        res.push_back(cnt);
        for(int i=m-1;i>=1;i--)//逆序依次连接所有边
        {
            cnt -= bind(vc[i].first,vc[i].second);
            res.push_back(cnt);
        }
 
        for(int i=res.size()-1;i>=0;i--)
            printf("%d\n",res[i]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值