Bone Collector II(背包 求第k优解)

C - Bone Collector II

 

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link: 

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602 

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum. 

If the total number of different values is less than K,just ouput 0.

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone. 

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 2 31). 

Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1

Sample Output

12
2
由于k的范围十分小 我们可以考虑将数组开成3维枚举第k解

我在枚举k时 运用了set 由于set的每次插入元素的复杂度都是logn所以 时间会比运用数组记录时间长的多

所以并不是所有的题都适用stl

运用数组的话 我们只需要每次判断ab数组的大小 并保持一定的顺序就可以避免排序的复杂度

附上性能拙劣的code

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<iostream>
#include<set>
using namespace std;
int co[1005];
int va[1005];
int dp[105][1005][35];//第i件物品 剩余体积 第几大
set <int,greater<int> > temp;//临时取前30 大的值
int main()
{
    int t;
    scanf("%d",&t);
    set<int,greater<int> >::iterator ite;
    while(t--)
    {
        int n,v,k;
        scanf("%d%d%d",&n,&v,&k);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++) scanf("%d",&va[i]);
        for(int i=1; i<=n; i++) scanf("%d",&co[i]);
        for(int i=1; i<=n; i++)
        {
            for(int j=0; j<=v; j++)
            {
                if(j<co[i])
                {
                    for(int  it=1;it<=k;it++)
                        dp[i][j][it]=dp[i-1][j][it];
                    continue;
                }
                if(temp.size()) temp.clear();
                for(int it=1; it<=k; it++)
                {
                    if(j>=co[i]) temp.insert(dp[i-1][j-co[i]][it]+va[i]);
                    temp.insert(dp[i-1][j][it]);
                }
                ite=temp.begin();
                //cout<<endl;
                for(int it=1; it<=k; it++)
                {

                    //cout<<*ite<<endl;
                    if(ite==temp.end()) break;
                    dp[i][j][it]=*ite;
                    ite++;
                }
                //out<<endl;
            }
        }
        printf("%d\n",dp[n][v][k]);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值