poj 2411 Mondriaan's Dream

Mondriaan’s Dream

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 16284 Accepted: 9420

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!
Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input
1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output
1
0
1
2
3
5
144
51205


【分析】
题意:给一个n*m的网格,用1*2的骨牌填满,求几种填法
比起poj3133,这题简直简单…
做轮廓线dp的时候筛一下不合法状态就ok,具体看注释蛤。


【代码】

//poj 2411 Mondriaan's Dream 
#include<iostream>
#include<cstring>
#include<cstdio>
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
int n,m,p,q;
long long dp[2][1<<15];
int main()
{
    int i,j,k,now;
    while(scanf("%d%d",&n,&m) && n && m)
    {
        memset(dp,0,sizeof dp);
        now=0;
        if(m>n) swap(n,m);
        dp[0][(1<<m)-1]=1;
        fo(i,0,n-1)
          fo(j,0,m-1)
          {
              now^=1;
              memset(dp[now],0,sizeof dp[now]);
              fo(k,0,(1<<m)-1)
              {
                  //1.如果a[i][j]不放,那么a[i-1][j]必须为1 
                  if(k&(1<<m-1))
                    dp[now][(k<<1)&((1<<m)-1)]+=dp[now^1][k];
                  //2.如果放一个细长的块,那么a[i-1][j]必须为0  
                  if(i && !(k&(1<<m-1)))
                    dp[now][((k<<1)&((1<<m)-1))|1]+=dp[now^1][k];
                  //3.如果放一个躺下的块,那么a[i][j-1]必须为0,且a[i-1][j]=1 
                  if(j && !(k&1) && (k&(1<<m-1)))
                    dp[now][((k<<1)&((1<<m)-1))|3]+=dp[now^1][k];
              }
          }
        printf("%lld\n",dp[now][(1<<m)-1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值